CREATING SUBNETS 3  

Wednesday, October 29, 2008


this is the final one and interesting one


130.100.0.0

we need 30 subnets

each subnet with atleast 1000 hosts


class b ..

so subnet mask is 255.255.x.x

we need 30 right .. so tick in the subnet table until we meet the requirement

after looking at the table ..we ticked 5 of the subnet ones ..so even tick the 5 bits of upper subnets

it ends at 248 so our subnet mask is 255.255.248.0

now we have unticked three of them

(252 ,254 , 255 ***********important (3 of the unticked third octet and 8 of the remaining 4th octet so a total of 11..so tick 11 in the host bits portion and

subtract 2 to get the number of hosts)


the crucial one


bits----------128-------64-------32------16-----8----4------2-----1
subnets


128-------------*

192-------------*

224------------*

240-------------*

248--------------*

252

254

255


powers of 2 ------ subnets--------------------hosts (-2)

2--------------------*------------------------------*

4---------------------*------------------------------*

8----------------------*------------------------------*

16---------------------*-------------------------------*

32----------------------*(we met 30 here)-------------*

64------------------------------------------------------*

128-----------------------------------------------------*


256------------------------------------------------------*


512-------------------------------------------------------*


1024-----------------------------------------------------*

2048----------------------------------------------------* (total of 11 bits ticked 2048 - 2 = 2046 hosts / subnet)





hope this helped anyone ... any comments / suggestions are warmly welcomed ...


regards
rakesh

EASILY DESIGN SUBNETS 2  


200.100.20.0

9 subnets

each host needs atleast 10 hosts



class c addr ..so subnet mask is 255.255.255.x

now we need 9 subnets .. tick in the subnets coloum till we meet the requirement of 9 subnets ...

so look at the table .. we have ticked 4 of them .. so tick 4 bits in the upper subnet table

it stopped at 240 so our subnet mask is 255.255.2555.240

now we are left with 4 empty bits (248 , 252, 254 , 255) tick them under hosts ... and subtract two we are done

the crucial one


bits------------128--------64--------32-------16-------8------4------2------1
subnets


128-----------------*

192----------------*

224---------------*

240------------------*

248

252

254

255


powers of 2 ------ subnets-------------------hosts (-2)

2------------------------*---------------------------*

4------------------------*----------------------------*

8-----------------------*-----------------------------*
we have met the requirement of 9 subnets
16-----------------------*-----------------------------*(16-2 = 14 hosts )

32

64

128


256


512


1024

EASILY DESIGN SUBNETS  


this is what i liked in this tutorial.. designing subnets was never been easy for me and also very much confusing .. thanks to the author iam now satisfied with my designing subnets knowledge

192.168.1.0

4 subnets required

each subnet needs at least 10 hosts


firstly for its a class c addr ..so for our subnet mask it should have three octets full ... as class c is 255.255.255.x

so

fill it out as 255.255.255.x

now we need 4 subnets ... so tick till we meet our subnet requirements in the table

now as marked two bits under subnets ...you also need to mark two bits under subnets in the upper colomn



hence in this way this can be determined

as it stopped at 192..our subnet mask is ends with 192..there fore our subnet mask is 255.255.255.192

now as you tick two bits under upper subnets coloum...there are 6 bits remaining unticked right ..(unticked 224 240 248 252 254 255 total 6)

tick them under hosts wink.gif

look the table and come back ... we are left at 64 ..as we need to subtract two for broadcast and subnets .. there would be 62

solve simply
the crucial one


bits---------128--------64--------32------16-------8----4-----2------1

subnets


128-------*

192-------*

224

240

248

252

254

255


powers of 2 ------- subnets------------------hosts (-2)

2--------------------*------------------------------------*

4--------------------*-------------------------------------*

8----------------------------------------------------------*

16----------------------------------------------------------*

32----------------------------------------------------------*

64------------------------------------------------------------*

128


256


512


1024

CLASS A EXAMPLE 2  

last class a

20.100.55.3 / 26

multiple of 8 again .. it ends at 24...to get to 26 we need to have two bits .. so tick two bits vertically and horizontally in the table two ..

under subnets it stopped at 192

so our subnet mask is

255.255.255.192

and under bits it stopped at 64 .. so the subnets increment at rate of 64

lets start with zero subnet

subnet------------firsthost---------lasthost----------------broadcast

20.0.0.0

20.0.0.64

20.0.0.128

20.0.0.192

etc

etc till our ip

20.100.55.0----------20.100.55.1----------20.100.55.62---------20.100.55.63

our ip falls here ..

20.100.55.64

20.100.55.128

20.100.55.192


hence in this way this can be determined




the crucial one


bits---------128-------64-----32------16----8--------4-----2---------1
subnets-----*-----------*


128---------------------------------*

192---------------------------------*

224

240

248

252

254

255


powers of 2 --------------------------------------- subnets--------------------------------------hosts (-2)

2

4

8

16

32

64

128


256


512


1024

CLASS A EXAMPLE LAST ONE  

moving on to class a




10.210.204.70/12

multiples of 8 .... 12 is not greater than 16 .. so multiple of 8 satisfying it is ...8...so to get 12 we need to add 4 more bits ...

there fore ..tick 4 bits horizontally and 4 bits vertically and game over

seeing the table under subnets it stops at 240..so remember we have only one multiple of 8 .. so only one 255 in subnet mask..

therefore subnet mask is 255.240.0.0

now seeing under bits section...it has stopped at 16 so...multiples of 16 or difference of 16 ..we need to start with zero ---- for class a x.0.0.0

subnet------------firsthost--------------lasthost-----------broadcast

10.0.0.0

10.16.0.0

10.32.0.0

etc till our ip

10.208.0.0-------10.208.0.1---------10.223.255.254-----------10.223.255.255

this satisfies our ip

10.224.0.0





hence in this way this can be determined




the crucial one


bits------------128------------64-----------32------16---8---4----2-- --1
subnets ---------*--------------*------------*------*


128--------------*

192-------------*

224--------------*

240--------------*

248

252

254

255


powers of 2 --------------------------------------- subnets--------------------------------------hosts (-2)

2

4

8

16

32

64

128


256


512


1024

CLASS B TRICKY EXAMPLE  

this is some what tricky .. please do clear the concepts in the above cases

191.20.56.65 / 25 ------------

as usual ...greater than 24 .. so we need to add one more bit to make it 25 .. so tick in the table two one start horizontally and vertically and rest is gone

so seeing it ... we got under subnets the value is 128 .. so the subnet mask is

255.255.255.128

now going on with next ..we got 128 under bits so the difference is 128..but now we need to have four octet subnets for every third octet one .. if this

confuses you see the below table

start with 0------------since class b -------------x.x.0.0

subnet------------firsthost-------------lasthost------------broadcast

191.20.0.0

191.20.0.128

191.20.1.0

191.20.1.128

191.20.2.0

191.20.2.128

etc etc till our ip

191.20.56.0----------191.20.56.1-------191.20.56.126---------191.20.56.127

this satisfies our ip

191.20.56.128


hence in this way this can be determined




the crucial one


bits----------128--------64---------32---------16-------8------4------2-------1
subnets--------*


128 -------------------*

192

224

240

248

252

254

255


powers of 2 --------------------------------------- subnets--------------------------------------hosts (-2)

2

4

8

16

32

64

128


256


512


1024

CLASS B SUBNETTING  


moving on to class b

150.200.155.23/18

18 bits .. so multiples of 8 ... now 24 will not work as 18 is less than 24 .. so next 8 multiple is 16 ... so ... we need two more bits from 16 to 18

so go to table two tick two horizontally and two vertically ... and you are done


so seeing the table ... under subnets it stopped at 192.. remember we had only 16 bits now not 24 .. so our mask would be

255.255.192.0

now see under the bits table ... we are stopped at 64 .. so for this we need to have increments of 64 ... as usual start with 0

subnet---------------firsthost------------lasthost----------broadcast

150.200.0.0

150.200.64.0

150.200.128.0----150.200.128.1-------150.200.191.254-----150.200.191.255

our ip statisfies here

150.200.192.0


hence in this way this can be determined




the crucial one


bits------128-------------------64----------32--------16------8----4----2-------1
subnets --------*---------------------*


128-----------------------*

192-----------------------*

224

240

248

252

254

255


powers of 2 --------------------------------------- subnets--------------------------------------hosts (-2)

2

4

8

16

32

64

128


256


512


1024

Anothe class c example  

another class c example




192.200.200.167 / 28


now again count till 24 ...now are left with another 4 bits ... rest is childs play as usual... tick 4 horizontally and 4 vertically in the second table...

after seeing the table and seeing the number under subnets it is 240 and under bits it is 16 .. so simple subnet mask ends with 240 and it has a diff of 16 for every

so our subnet mask is ... 255.255.255.240


subnet we write


so we will start with 0 as usual


subnet--------------firsthost------------lasthost--------------broadcast

192.200.200.0-------192.200.200.1--------------------

192.200.200.16

192.200.200.32

192.200.200.48

etc

etc with increments of 16

192.200.200.160-----192.200.200.161-----192.200.200.174---192.200.200.175

our need fills here


192.200.200.176





hence in this way this can be determined




the crucial one


bits-------128------64-------32---16---8---4----2-----1
subnets ----* -------*---------*-----*


128-----------*

192-----------*

224-----------*

240-----------*

248

252

254

255


powers of 2 --------------------------------------- subnets--------------------------------------hosts (-2)

2

4

8

16

32

64

128


256


512


1024

SUBNETTING EXAMPLE 1 CLASS C  

this is the first example


class c

identify subnet , first and last host of the following ip or what ever it may be

here is the example 1

192.168.12.68 / 25 ***************** 25 bits so ...

firstly count in multiples of 8 till we get 24 .... as one octet has 8 bits right ...

so 8 + 8 + 8 + (1) --------- left ..


rest is the childs play... really .. now go to the table 2 and borrow or tick 1 bit horizontally and vertically so in this case

see the table two and come back you will find number 128 under subnets and 128 under bits ..

so subnet is 128 and bits 128 indicate that difference should be 128 --->we will see this point later

so our subnet is


255.255.255.128



as we all know we need to start any subnet with 0 .. so start it


subnet---------firsthost---------------------lasthost-------broadcast

192.168.12.0------192.168.12.1-----192.168.12.126-----192.168.12.127

(see the difference of 128
which we got in bits )

192.168.12.128-------------------------------


hence in this way it can be determined


the crucial one


bits------128-------64-- ---32--------16--------8------4----2------1

subnets *** *(1 bit vertically)


128 **** *(1 bit horizontally)

192

224

240

248

252

254

255


powers of 2 --------------------------------------- subnets--------------------------------------hosts (-2)

2

4

8

16

32

64

128


256


512


1024


hence in this way it can be determined

more examples to follow .. let me know if this makes sense to anyone

regards
Rakesh



SuBnEtTiNG ????? ITS DAMN EASY .. I LEARNT IT TODAY  

i found these techniques in subnetting secrets and found them very effective hoping that these will help you too


firstly you need to have remember two tables ...

1.basic table of first host , last host table

2.the crucial one to all calculation table ...

here are the two


subnet ----------firsthost------------lasthost---------------broadcast




hence in this way this can be determined




the crucial one


bits---------128------64-------32-------16----8----4------2-----1
subnets


128

192

224

240

248

252

254

255


powers of 2 --------- subnets--------------hosts (-2)

2

4

8

16

32

64

128


256


512


1024


********************************************************************************
*********************************************









let me check with the formatter , if it comes correctly i will go ahead explaining the
concept if not i will host it to image shack and explain it


regards
RAKESH

Various Show Commands  

Tuesday, October 28, 2008

r2#show ip ospf data

OSPF Router with ID (10.1.2.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 718 0x80000003 0x00840E 4
10.1.2.1 10.1.2.1 717 0x80000002 0x003F81 4
10.1.3.1 10.1.3.1 717 0x80000002 0x008D58 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.1.200.1 10.1.1.1 718 0x80000001 0x00EE3B
r2#
as#1
[Resuming connection 1 to r1 ... ]

r1#show ip ospf data

OSPF Router with ID (10.1.1.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 724 0x80000003 0x00840E 4
10.1.2.1 10.1.2.1 725 0x80000002 0x003F81 4
10.1.3.1 10.1.3.1 725 0x80000002 0x008D58 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.1.200.1 10.1.1.1 724 0x80000001 0x00EE3B
r1#
as#show ip ospf

as#1
[Resuming connection 1 to r1 ... ]

r1#show ip ospf
Routing Process "ospf 1" with ID 10.1.1.1
Start time: 00:00:13.112, Time elapsed: 00:13:46.552
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 3
Area has no authentication
SPF algorithm last executed 00:12:58.852 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 4. Checksum Sum 0x023F22
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

r1#
as#2
[Resuming connection 2 to r2 ... ]

r2#show ip ospf
Routing Process "ospf 1" with ID 10.1.2.1
Start time: 00:00:13.112, Time elapsed: 00:13:54.152
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 3
Area has no authentication
SPF algorithm last executed 00:13:09.280 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 4. Checksum Sum 0x023F22
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

r2#
as#3
[Resuming connection 3 to r3 ... ]

r3#show ip ospf
Routing Process "ospf 1" with ID 10.1.3.1
Start time: 00:00:03.300, Time elapsed: 00:14:33.924
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm last executed 00:13:19.404 ago
SPF algorithm executed 2 times
Area ranges are
Number of LSA 4. Checksum Sum 0x023F22
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

r3#
as#1
[Resuming connection 1 to r1 ... ]

r1#show ip ospf int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 0 10.1.200.1/24 50 DR 2/2
Se2/0 1 0 10.1.100.1/24 64 P2P 1/1
Lo1 1 0 10.1.1.1/24 1 P2P 0/0
r1#
as#2
[Resuming connection 2 to r2 ... ]

r2#show ip ospf int breif
^
% Invalid input detected at '^' marker.

r2#show ip ospf int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 0 10.1.200.2/24 1 DROTH 2/2
Se2/0 1 0 10.1.100.2/24 64 P2P 1/1
Lo2 1 0 10.1.2.1/24 1 P2P 0/0
r2#
as#3
[Resuming connection 3 to r3 ... ]

r3#show ip ospf int
FastEthernet0/0 is up, line protocol is up
Internet Address 10.1.200.3/24, Area 0
Process ID 1, Router ID 10.1.3.1, Network Type BROADCAST, Cost: 100
Transmit Delay is 1 sec, State BDR, Priority 50
Designated Router (ID) 10.1.1.1, Interface address 10.1.200.1
Backup Designated router (ID) 10.1.3.1, Interface address 10.1.200.3
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 10.1.1.1 (Designated Router)
Adjacent with neighbor 10.1.2.1
Suppress hello for 0 neighbor(s)
Loopback3 is up, line protocol is up
Internet Address 10.1.3.1/24, Area 0
Process ID 1, Router ID 10.1.3.1, Network Type POINT_TO_POINT, Cost: 1
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
r3#show ip ospf int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 0 10.1.200.3/24 100 BDR 2/2
Lo3 1 0 10.1.3.1/24 1 P2P 0/0
r3#

Running Configs for R2 and R3  

r2#show run
Building configuration...

Current configuration : 1514 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.1.200.2 255.255.255.0
ip ospf priority 48
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
interface Serial2/0
ip address 10.1.100.2 255.255.255.0
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.1.2.1 0.0.0.0 area 0
network 10.1.100.2 0.0.0.0 area 0
network 10.1.200.2 0.0.0.0 area 0
!
ip http server
!
!
!
!
control-plane
!
alias exec siib show ip int brief
alias exec sir show ip route
alias exec sio show ip ospf
alias exec siod show ip ospf data
alias exec sioi show ip ospf int
alias exec sr show run
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

r2#

********************************************************************************

r3#show run
Building configuration...

Current configuration : 1485 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.1.200.3 255.255.255.0
ip ospf cost 100
ip ospf priority 50
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/1
no ip address
shutdown
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.1.3.1 0.0.0.0 area 0
network 10.1.200.3 0.0.0.0 area 0
!
ip http server
!
!
!
!
control-plane
!
alias exec siib show ip int brief
alias exec sir show ip route
alias exec sio show ip ospf
alias exec siod show ip ospf data
alias exec sioi show ip ospf int
alias exec sr show run
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

r3#

Running Configs for routers  

as#show run
Building configuration...

Current configuration : 1149 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname as
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
ip host r1 2001 1.0.0.2
ip host r2 2002 1.0.0.2
ip host r3 2003 1.0.0.2
ip host r4 2004 1.0.0.2
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 1.0.0.1 255.255.255.0
duplex auto
speed auto
!

ip http server
!
ip route 0.0.0.0 0.0.0.0 1.0.0.2
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

as#

***********************************************************************************


r1#show run
Building configuration...

Current configuration : 1533 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.1.200.1 255.255.255.0
ip ospf cost 50
ip ospf priority 100
duplex auto
speed auto
!

!
interface Serial2/0
ip address 10.1.100.1 255.255.255.0
serial restart-delay 0
!

!
router ospf 1
log-adjacency-changes
network 10.1.1.1 0.0.0.0 area 0
network 10.1.100.1 0.0.0.0 area 0
network 10.1.200.1 0.0.0.0 area 0
!
ip http server
!
!
!
!
control-plane
!
alias exec siib show ip int brief
alias exec sir show ip route
alias exec sio show ip ospf
alias exec siod show ip ospf data
alias exec sioi show ip ospf int
alias exec sr show run
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

r1#

LAB 3-1 OSPF  


i took darby weavers advice and went after train.signal and man he has details ... first few times i felt bored and closed the window ... but after the third i began to see his notes and points both becoming valuble ... now no longer iam considering to go after cisco press as i will take the book exam certification guide rather than student guide ... the download of ccnp.video mentor is on progress and i after that i will even see that .. and then go on for ccie training videos on ospf ... i thought of checking my lab practices and level on ccnp ..and they are just improving .. i have began labbing from cisco lab guide for ccnp and this is the first of the 5 topologies .

not in very much of details as the first lab is just a starter on puppy things like priorities and starting the ospf proc itself ....

here is the topo and router show runs ..... after iam done with labs i would post the important points as what i found in both cb.t and train.signal , video.mentor..

lab 3-1

Lab 3-1 Single-Area OSPF Link Costs and Interface Priorities
Learning Objectives
• Configure single-area OSPF on a router
• Advertise loopback interfaces into OSPF
• Verify OSPF adjacencies
• Verify OSPF routing information exchange
• Modify OSPF link costs
• Change interface priorities
• Utilize debugging commands for troubleshooting OSPF
Topology

Scenario

You are responsible for configuring the new network to connect your company’sEngineering, Marketing, and Accounting departments, represented by the
loopback interfaces on each of the three routers. The physical devices have justbeen installed and connected by Fast Ethernet and serial cables. Configure
OSPF to allow full connectivity between all departments.You will be using the same physical topology for the labs in this module, so
save your configuration for use in the next lab exercise.






















running configs and show commands to follow ...


regards
RAKESH

O.S.P.F  

for the last week or so there were no updates on study materials and techs because of two reasons ..

iam presently undegoing series of semister exams which are still for one month and secondly i have been watching the cbt nuggest so potentially i couldnt write it to this diary ...

seeing all the videos one thing i could see my self is ospf is really big and vast .. and a real busy routing protocol ..

the things i learned from cbt . these are brief and i did lab on cbt .. yet left with cisco press and cisco lab . i happened to hear the ospf routing proc by scott morris of ip expert and man o man i was amazed and thrilled about the minute details leaving the nat part which i still to explore ... iam finding real kick off just waiting for my completion of sem exams after that i could happily study for another 3 months without any exams in coll lol ...

the most important topics are

1.ospf summaraisation options (abr and asbr having differences)

2.area types and basic use of areas (less areas more probablity of buring your cpu in gns3 jus kidding)

3.lsa types (these are huge and i had a lot of fun while configuring)

4.stub and different stubs like nssa and tsa (california stuff dude )

5.ospf authentication (md5 algorithm and simple text authentication)

6.dr and bdr elections

7.network types (point to point and p2mp , nbma , broadcast ,p2mp n b )

8.a sample of redistribution and auto adjusting cost with no pain at all .

9.lot of wiered stuff with ospf with lot of fun and misconfiguring and frame-relay stuff

10.i had to force myself to exactly configure frame-relay and its working for cbt labbing . if any one wants to configure feel free to ask me to post the methods ..as it is of all basic stuff

11.went to see 3 movies with frnds lol


i would start off with ccnp bsci cisco press text book from today on wards and would update with important points ...

regards
RAKESH

FEW REVISIONS  

Wednesday, October 8, 2008

well lab 2-4b is as same as lab 2-4 a for something called adtran configuration which iam not aware of .. i have changed the ios version and now iam happy with my results ...

to compare these are the few results

before manaul summaraisaiton

before summaraisation

east#sie topo
IP-EIGRP Topology Table for AS(1)/ID(10.2.161.161)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.2.0.0/19, 1 successors, FD is 128256
via Connected, Loopback1
P 10.3.0.0/19, 1 successors, FD is 2809856
via 172.16.124.1 (2809856/2297856), Serial1/1
P 10.1.0.0/19, 1 successors, FD is 2297856
via 172.16.124.1 (2297856/128256), Serial1/1
P 10.2.32.0/19, 1 successors, FD is 128256
via Connected, Loopback33
P 10.3.32.0/19, 1 successors, FD is 2809856
via 172.16.124.1 (2809856/2297856), Serial1/1
P 10.1.32.0/19, 1 successors, FD is 2297856
via 172.16.124.1 (2297856/128256), Serial1/1
P 10.2.64.0/19, 1 successors, FD is 128256
via Connected, Loopback65
P 10.3.64.0/19, 1 successors, FD is 2809856
via 172.16.124.1 (2809856/2297856), Serial1/1
P 10.1.64.0/19, 1 successors, FD is 2297856
via 172.16.124.1 (2297856/128256), Serial1/1
P 10.2.96.0/19, 1 successors, FD is 128256
via Connected, Loopback97
P 10.3.96.0/19, 1 successors, FD is 2809856
via 172.16.124.1 (2809856/2297856), Serial1/1
P 10.1.96.0/19, 1 successors, FD is 2297856
via 172.16.124.1 (2297856/128256), Serial1/1
P 10.2.128.0/19, 1 successors, FD is 128256
via Connected, Loopback129
P 10.3.128.0/19, 1 successors, FD is 2809856
via 172.16.124.1 (2809856/2297856), Serial1/1
P 10.1.128.0/19, 1 successors, FD is 2297856
via 172.16.124.1 (2297856/128256), Serial1/1
P 10.2.160.0/19, 1 successors, FD is 128256
via Connected, Loopback161
P 10.3.160.0/19, 1 successors, FD is 2809856
via 172.16.124.1 (2809856/2297856), Serial1/1
P 10.1.160.0/19, 1 successors, FD is 2297856
via 172.16.124.1 (2297856/128256), Serial1/1
P 172.16.124.0/29, 1 successors, FD is 2169856
via Connected, Serial1/1
east#

after summaraisation


east#sie top
IP-EIGRP Topology Table for AS(1)/ID(10.2.161.161)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.2.0.0/16, 1 successors, FD is 128256
via Summary (128256/0), Null0
P 10.2.0.0/19, 1 successors, FD is 128256
via Connected, Loopback1
P 10.3.0.0/16, 1 successors, FD is 2809856
via 172.16.124.1 (2809856/2297856), Serial1/1
P 10.1.0.0/16, 1 successors, FD is 2297856
via 172.16.124.1 (2297856/128256), Serial1/1, serno 54
P 10.2.32.0/19, 1 successors, FD is 128256
via Connected, Loopback33
P 10.2.64.0/19, 1 successors, FD is 128256
via Connected, Loopback65
P 10.2.96.0/19, 1 successors, FD is 128256
via Connected, Loopback97
P 10.2.128.0/19, 1 successors, FD is 128256
via Connected, Loopback129
P 10.2.160.0/19, 1 successors, FD is 128256
via Connected, Loopback161
P 172.16.124.0/29, 1 successors, FD is 2169856
via Connected, Serial1/1


and using neigbor command change of multicast to unicast this is the debug thing

east#debug eigrp packets hello
EIGRP Packets debugging is on
(HELLO)
east#
*Mar 1 01:06:31.551: EIGRP: Sending HELLO on Loopback161
*Mar 1 01:06:31.551: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 01:06:31.555: EIGRP: Received HELLO on Loopback161 nbr 10.2.161.161
*Mar 1 01:06:31.555: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
east#
*Mar 1 01:06:32.623: EIGRP: Sending HELLO on Loopback97
*Mar 1 01:06:32.623: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 01:06:32.627: EIGRP: Received HELLO on Loopback97 nbr 10.2.97.97
*Mar 1 01:06:32.627: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
east#
*Mar 1 01:06:34.131: EIGRP: Sending HELLO on Loopback33
*Mar 1 01:06:34.131: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 01:06:34.135: EIGRP: Received HELLO on Loopback33 nbr 10.2.33.33
*Mar 1 01:06:34.135: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
*Mar 1 01:06:34.407: EIGRP: Sending HELLO on Loopback65
*Mar 1 01:06:34.407: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
*Mar 1 01:06:34.411: EIGRP: Received HELLO on Loopback65 nbr 10.2.65.65
*Mar 1 01:06:34.411: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0
*Mar 1 01:06:34.643: EIGRP: Sending HELLO on Loopback129
*Mar 1 01:06:34.643: AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
east#


these are the few things to high light .. i have completed my eigrp and looking foreward for ospf ....

SUMMING UP  

rather than presenting with running configs it will be better off to mention the commands i used in this ... because i too never understood what those frame-relay commands were meant for .. so i wont post any of the configs till my understanding ... here are the commands i learnt in this ..



these are not the configs but just a revision sort of thing for frame-relay configs

CODE
frame-relay switching
int s1/0
encapsulation frame-relay
clock rate 128000
frame-relay lim-type cisco
frame-relay intf-type dce
frame-relay route 102 interface s1/1 201



CODE
this is for east

frame-relay map ip 172.16.124.2 255.255.255.248 broadcast
frame-relay map ip 172.16.124.3 255.255.255.248 broadcast

frame-relay map ip 172.16.124.1 255.255.255.248 -----------------------> this is the important option .. this is to include our own local interface



bandwidth percent command
CODE
ip bandwidth-percent eigrp 1 40 --------> to make that interface bandwith as 40% in as 1


by far most important point is to avoid split horizon rule in frame-relay other wise router will stop sending updates to other ..

CODE
config-if#no ip split-horizon eigrp 1




this turns off split horizon

the beautiful part is this

making eigrp as unicast rather than multicast

to make this use neig command

CODE
router eigrp 1
neighbor 172.16.124.1 serial 1/0 ------> example


these are the points i saw interesting .. the other lab to follow is the lab named adtran i didnt even heard that of lol ....or might have forgotten update with you asap

LAB 2-4A AND 2-4B  


The worst of lab experience is for these two labs lol... yes making a router as a frame-relay switch..nothing went on well for me .. the topology tables were not updated and i had to do this lab for thrice with no success lol .... i will try it again on original routers in the evening and wil let you know what exactly are the points .

as far as steps and points are concerned nothing special in concept except making the one of the router configure to avoid split horizon rule with eigrp as number ... and bandwidth percent command to limit bandwith on the interface to our will ... apart from these two points the rest of all are walk in the park for understanding and not that great for impelementing ..lol..i think with this lab i had started to see the ccie hell i guess rofl ...

so this is the question and topology



















Lab 2-4a EIGRP Frame Relay Hub and Spoke: Router Used As Frame Switch
Learning Objectives
• Review basic configuration of EIGRP on a serial interface
• Configure the bandwidth-percent command
• Configure EIGRP over Frame Relay hub and spoke
• Use EIGRP in non-broadcast mode
• Enable EIGRP manual summarization in topologies with discontiguous major
networks

Note: Given the diversity of router models and the differing naming conventions for
serial interfaces (S0, S0/0, S0/0/0), the interface numbers on your devices will probably
differ from those in the topology diagram. The same is true for which side of the link is
DCE or DTE. You should always draw your network diagram to reflect your topology. If
2 - 21 CCNP: Building Scalable Internetworks v5.0 - Lab 2-4a Copyright © 2006, Cisco Systems, Inc

you are uncertain which side of the connection is DCE, use the show controllers serial
command:
HQ#show controllers serial0/0/0
Interface Serial0/0/0
Hardware is GT96K
DCE V.35, clock rate 2000000
Scenario

You are responsible for configuring and testing the new network that connects
your company’s headquarters and east and west branches. The three locations
are connected over hub-and-spoke Frame Relay, using the company
headquarters as the hub. Model each branch office’s network with multiple
loopback interfaces on each router, and configure EIGRP to allow full
connectivity between all departments.
To simulate the Frame Relay WAN connections, use a router with three serial
ports configured as a frame switch. The router configuration is described in


running configs as follows

COMMANDS I ENCOUNTERED  

AND TO SUM UP THESE ARE THE COMMANDS I ENCOUNTERED

CODE
R1# conf t
R1(config)# key chain EIGRP-KEYS
R1(config-keychain)# key 1
R1(config-keychain-key)# key-string cisco


R1# show key chain


R1# conf t
R1(config)# interface serial 0/0/0
R1(config-if)# ip authentication key-chain eigrp 1 EIGRP-KEYS
R1(config-if)# ip authentication mode eigrp 1 md5


R1# show ip eigrp interfaces detail


R1#debug eigrp packets


R1# conf t
R1(config)# interface serial 0/0/0
R1(config-if)# ip hello-interval eigrp 1 2
R1(config-if)# ip hold-time eigrp 1 8


R1# show ip eigrp 1 interfaces detail serial 0/0/

HELLO TIMERS  

A SIMPLE HOLD AND HELLO TIME CHANGING CONFIG

r1#sie n
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 10.1.1.3 Fa0/0 10 00:09:54 376 2256 0 90
2 172.16.13.2 Se1/1 12 00:11:11 245 1470 0 91
1 10.1.1.2 Fa0/0 14 00:13:31 311 1866 0 110
0 172.16.12.2 Se1/0 7 00:15:04 271 1626 0 109 --- ONLY THIS INTERFACE HAS BEEN GIVEN A HOLD OF 8





r2#sie n
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
3 172.16.23.2 Se1/1 11 00:07:43 166 996 0 92
0 10.1.1.3 Fa0/0 14 00:10:30 325 1950 0 90
2 10.1.1.1 Fa0/0 13 00:14:08 191 1146 0 75
1 172.16.12.1 Se1/0 7 00:15:40 156 936 0 76
r2#



r1#sie int detail s1/0
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 271 0/15 1051 0
Hello interval is 2 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 21/25
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 9
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
r1#



r2#sie int detail s1/0
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 156 0/15 787 0
Hello interval is 2 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 15/32
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 9
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
r2#


this is after changing entire hold and hello time ..


r1#
r1#sie int detail
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 271 0/15 1051 0
Hello interval is 2 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 21/25
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 9
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
Se1/1 1 0/0 245 0/15 923 0
Hello interval is 2 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 16/22
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 7
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use unicast
Fa0/0 2 0/0 343 0/2 1392 0
Hello interval is 2 sec
Next xmit serial

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Un/reliable mcasts: 0/12 Un/reliable ucasts: 29/21
Mcast exceptions: 7 CR packets: 4 ACKs suppressed: 3
Retransmissions sent: 8 Out-of-sequence rcvd: 0
Authentication mode is md5, key-chain is "EIGRP-KEYS"
Use multicast
Lo1 0 0/0 0 0/1 0 0
Hello interval is 5 sec
Next xmit serial
Un/reliable mcasts: 0/0 Un/reliable ucasts: 0/0
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Authentication mode is not set
Use multicast
r1#

Design by Blogger Buster | Distributed by Blogging Tips