LAB 2-1 EIGRP CONFIGS AND EXPLANATIONS  

Friday, September 19, 2008

This is the lab topology with configs ..... i do paste this configs because its a kind of back up for me and its a kind of good practise for people who try in future to just copy and paste these configs...

















so to start of with this is the topology ... this is straight from cisco lab guide edition version 5 bsci ...


theres a mistake in printing ip addresses 10.1.100.0/24 belongs to fa0/0 of r1
10.1.200.0/24 belongs to s1/0 of r1




so to start of with the given question and objectives :

LAB 2-1

LEARNING OBJECTIVES

1.Configuring EIGRP on an Interface

2.Configuring Bandwidth command to limit Eigrp bandwidth

3.verify Eigrp adjacencies

4.verify eigrp routing info exchage

5.utilize debugging commands for troubleshooting EIGRP

6.CHALLENGE: TEST covergence when topology change occurs



SCENARIO

You are responsible for configuring the new network to connect your companys engineering , Marketing and accounting departments
represented by loop back interfaces on three routers . the physical devices have just been installed and connected by fast ethernet
and serial cables . Your task is to configure eigrp to enable full connectivity between all departments


i will be following by my ideas , staratagies and way i thought and problems faced after this message .. so these are the configs

config for R1

CODE
r1#show run
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.1 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
bandwidth 64000
ip address 10.1.200.1 255.255.255.0
serial restart-delay 0
!


router eigrp 1
network 10.1.1.0 0.0.0.255
network 10.1.100.0 0.0.0.255
network 10.1.200.0 0.0.0.255
network 10.0.0.0
auto-summary
!
alias exec siib show ip int breif siib
alias exec sir show ip route
alias exec sie show ip eigrp
alias exec si show interface
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end


r1#siib
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.100.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 10.1.200.1 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback1 10.1.1.1 YES manual up up
r1#


r1#sie topo
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.1.3.0/24, 1 successors, FD is 409600
via 10.1.100.3 (409600/128256), FastEthernet0/0
P 10.1.2.0/24, 1 successors, FD is 409600
via 10.1.100.2 (409600/128256), FastEthernet0/0
via 10.1.200.2 (679936/128256), Serial1/0
P 10.1.1.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 192.168.100.0/24, 1 successors, FD is 409600
via 10.1.100.3 (409600/128256), FastEthernet0/0
P 10.1.100.0/24, 1 successors, FD is 281600
via Connected, FastEthernet0/0
P 10.1.200.0/24, 1 successors, FD is 551936
via Connected, Serial1/0
r1#


r1#sir
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 5 subnets
D 10.1.3.0 [90/409600] via 10.1.100.3, 00:04:51, FastEthernet0/0
D 10.1.2.0 [90/409600] via 10.1.100.2, 00:04:49, FastEthernet0/0
C 10.1.1.0 is directly connected, Loopback1
C 10.1.100.0 is directly connected, FastEthernet0/0
C 10.1.200.0 is directly connected, Serial1/0
D 192.168.100.0/24 [90/409600] via 10.1.100.3, 00:04:51, FastEthernet0/0
r1#



config for R2

CODE
r2#show run
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.2 255.255.255.0
duplex auto
speed auto
!
!
interface Serial1/0
bandwidth 64000
ip address 10.1.200.2 255.255.255.0
serial restart-delay 0
!

router eigrp 1
network 10.1.2.0 0.0.0.255
network 10.1.100.0 0.0.0.255
network 10.1.200.0 0.0.0.255
network 10.0.0.0
auto-summary
!

alias exec siib show ip int breif siib
alias exec sir show ip route
alias exec sie show ip eigrp
alias exec si show interface
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

r2#



config for R3
CODE
r3#show run
!
interface Loopback1
ip address 192.168.100.1 255.255.255.252
!
interface Loopback2
ip address 192.168.100.5 255.255.255.252
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.100.3 255.255.255.0
duplex auto
speed auto
!

!
router eigrp 1
network 10.1.3.0 0.0.0.255
network 10.0.0.0
network 192.168.100.0 0.0.0.3
network 192.168.100.4 0.0.0.3
network 192.168.100.0
auto-summary
!

alias exec siib show ip int brief siib
alias exec sir show ip route
alias exec sie show ip eigrp
alias exec si show interface
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end


tcl script for testing ping connectivity
these are becoming handy for me .. write all of you ips in a note pad and the method is as mentioned in above posts


CODE
r2(tcl)#tclsh

r2(tcl)#foreach address {
+>(tcl)#10.1.1.1
+>(tcl)#10.1.200.1
+>(tcl)#10.1.200.2
+>(tcl)#10.1.100.1
+>(tcl)#10.1.100.2
+>(tcl)#10.1.100.3
+>(tcl)#10.1.2.1
+>(tcl)#10.1.3.1
+>(tcl)#192.168.100.1
+>(tcl)#192.168.100.5
+>(tcl)#} {
+>(tcl)#ping $address
+>(tcl)#}

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 120/212/284 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/98/200 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 100/216/316 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/172/252 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.100.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.100.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/224/496 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/200/256 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/152/268 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/166/256 ms
r2(tcl)#


PING REPEAT TEST SHUTTING DOWN AND BRINGING UP FA 0/0 ON R1 TO SEE THE CONVERGENCE CHANGES I WAS CRAZY HERE LOL

CODE
r1(config-if)#shutdown
r1(config-if)#
*Mar 1 00:38:42.223: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.2 (FastEthernet0/0) is down: interface down
*Mar 1 00:38:42.239: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.3 (FastEthernet0/0) is down: interface down
r1(config-if)#
*Mar 1 00:38:44.039: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Mar 1 00:38:45.039: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
r1(config-if)#no shutdown
r1(config-if)#
*Mar 1 00:39:08.919: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:39:09.919: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
r1(config-if)#
*Mar 1 00:39:10.031: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.2 (FastEthernet0/0) is up: new adjacency
*Mar 1 00:39:10.059: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.3 (FastEthernet0/0) is up: new adjacency
r1(config-if)#



r3#ping 10.1.1.1 repeat 10000

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
.....!!
*Mar 1 00:07:06.387: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.1 (FastEthernet0/0) is down: holding time expired!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!
*Mar 1 00:07:23.419: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.100.1 (FastEthernet0/0) is up: new adjacency!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 98 percent (618/625), round-trip min/avg/max = 1/56/592 ms
r3#


to stop the bloody ping use ctrl + ^ key combinaition .. i called it bloody because i dint knew the
key and had to stop and start router thrice ... ehehehe



this is my first lab . the following messages follows how i approahed



regards
Rakesh

Design by Blogger Buster | Distributed by Blogging Tips